Addo Sign is temporarily out of operation

Incident Report for Addo Sign

Resolved

The platform is now online again.
Posted Apr 03, 2025 - 14:27 CEST

Investigating

We will be taking the platform offline to implement changes aimed at resolving the current active issues. The implementation will begin shortly and last for approx. 5 minutes.
Posted Apr 03, 2025 - 14:10 CEST
This incident affected: Webapplication, Signing portal, API, Email - Notification and Distribution, and Integrations.