Distribution of documents using e-Boks and Mit.dk are failing transactions

Incident Report for Addo Sign

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 08:00 CEST

Investigating

We are currently investigating this issue.
Posted Mar 27, 2025 - 08:00 CET
This incident affected: Webapplication.