Degraded performance

Incident Report for Addo Sign

Resolved

This incident has been resolved.
Posted May 14, 2025 - 19:41 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2025 - 17:39 CEST

Investigating

We are currently experiencing degraded performance with the service. Users may encounter timeouts in several areas. As a temporary workaround, please try your request again. Our team is working to implement a solution as quickly as possible.
Posted May 13, 2025 - 16:32 CEST
This incident affected: Webapplication, Signing portal, and API.