Issues distribution documents using Digital Post

Incident Report for Addo Sign

Resolved

This incident has been resolved. If you're still experiencing failed transactions, please reactivate the signing process.
Posted Apr 10, 2025 - 07:59 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2025 - 07:21 CEST

Update

We are continuing to investigate this issue.
Posted Apr 03, 2025 - 13:48 CEST

Investigating

We are currently investigating this issue.
Posted Mar 27, 2025 - 08:00 CET
This incident affected: Integrations.